Resolved
Our team has resolved the previous issue with in-app support chat. We appreciate your patience as we worked to resolve this issue.
Investigating
We are currently experiencing an issue with our in-app support chat where responses may not be displayed.
If you need assistance, please contact us via phone on +44 808 281 2527.
We apologize for the inconvenience and are working to resolve this as quickly as possible.